Skip to content
Laskyr

CVE-2026-39764: Radius Booking SQL injection vulnerability

critical 9.3 published 2026-10-06

Fixed in Radius Booking 1.0.20 (first release after the affected range)

Radius Booking 1.0.19 and older is affected by this SQL injection issue. Sites on 1.0.20 or newer are not affected; the latest release is 1.0.22.

Affected versions
1.0.19 and older
Fixed in
1.0.20 *
Latest version
1.0.22
Severity
Critical · CVSS 9.3
Active installs
500+
Type
SQL injection

* The source does not name a fixed version; this is the first wordpress.org release after the last affected version.

What an attacker needs

CVSS vector (score by Patchstack): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:L

What to do now

  1. Update Radius Booking to 1.0.20 or newer (the latest is 1.0.22): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Radius Booking issue. With WP-CLI: wp plugin get radius-booking --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

Unauthenticated SQL Injection in Radius Booking — Booking Calendar for Appointments & Services <= 1.0.19 versions.

Description from the CVE record, published by Patchstack (the CVE Numbering Authority), via the NVD entry for CVE-2026-39764.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit