Skip to content
Laskyr

phpoffice/phpspreadsheet security advisory

CVE-2026-34084: PhpSpreadsheet has SSRF/RCE in IOFactory::load when $filename is user controlled

CVE-2026-34084 is a critical-severity remote code execution vulnerability in the PHP package phpoffice/phpspreadsheet (CVSS 9.8), published 5 May 2026. The advisory does not name a fixed version. It can be exploited without an account.

critical 9.8 published 2026-05-05 · updated 2026-07-24

The advisory does not name a fixed version

This remote code execution issue affects phpoffice/phpspreadsheet in 5 release lines: <= 1.30.2; >= 2.0.0, <= 2.1.14; >= 2.2.0, <= 2.4.3; >= 3.3.0, <= 3.10.3; >= 4.0.0, <= 5.5.0. The newest release (5.10.0) is outside the affected range.

Affected versions
<= 1.30.2
>= 2.0.0, <= 2.1.14
>= 2.2.0, <= 2.4.3
>= 3.3.0, <= 3.10.3
>= 4.0.0, <= 5.5.0
Fixed in
not stated
Newest release
5.10.0
Severity
Critical · CVSS 9.8
Type
Remote code execution
CWE-502, CWE-918
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your phpoffice/phpspreadsheet version affected?

Run composer show phpoffice/phpspreadsheet in your project, then enter the version. We check it against this and every other known phpoffice/phpspreadsheet advisory.

Who can exploit CVE-2026-34084

CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Your app is only exposed if it uses the affected part of phpoffice/phpspreadsheet. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-34084 in phpoffice/phpspreadsheet

  1. Find the installed version: composer show phpoffice/phpspreadsheet. If you never required it yourself, composer why phpoffice/phpspreadsheet shows which package pulls it in.
  2. Update it: composer update phpoffice/phpspreadsheet --with-all-dependencies.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "phpoffice/phpspreadsheet": "^5.10.0" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-34084.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for remote code execution issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-34084 advisory

PhpSpreadsheet is a library for reading and writing spreadsheet files. In versions 1.30.2 and earlier, 2.0.0 through 2.1.14, 2.2.0 through 2.4.3, 3.3.0 through 3.10.3, and 4.0.0 through 5.5.0, when the filename argument to IOFactory::load() is user-controlled, an attacker can supply a PHP stream wrapper path (such as phar://, ftp://, or ssh2.sftp://) that passes the is_file() check in File::assertFile(). The phar:// wrapper triggers deserialization of the PHAR metadata, which can lead to remote code execution if a suitable gadget chain is available in the application. The ftp:// and ssh2.sftp:// wrappers can be used for server-side request forgery. This issue has been fixed in versions 1.30.3, 2.1.15, 2.4.4, 3.10.4, and 5.6.0.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-34084. Advisory title: “PhpSpreadsheet has SSRF/RCE in IOFactory::load when $filename is user controlled”.

References

Other phpoffice/phpspreadsheet advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit