Skip to content
Laskyr

CVE-2026-2839: Advanced Custom Fields missing authorization check vulnerability

medium 5.3 published 2026-10-28 · updated 2026-10-29

Fixed in Advanced Custom Fields 0.9.2.8 (first release after the affected range)

Advanced Custom Fields 0.9.2.7 and older is affected by this missing authorization issue. Sites on 0.9.2.8 or newer are not affected; the latest release is 0.9.2.8.

Affected versions
0.9.2.7 and older
Fixed in
0.9.2.8 *
Latest version
0.9.2.8
Severity
Medium · CVSS 5.3
Active installs
100,000+
Type
Missing authorization check

* The source does not name a fixed version; this is the first wordpress.org release after the last affected version.

What an attacker needs

CVSS vector (score by Wordfence): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

What to do now

  1. Update Advanced Custom Fields to 0.9.2.8 or newer: Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Advanced Custom Fields issue. With WP-CLI: wp plugin get acf-extended --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Advanced Custom Fields: Extended plugin for WordPress is vulnerable to unauthorized access of data and triggering of server-side actions in all versions up to, and including, 0.9.2.7. This is due to multiple AJAX handlers registered for unauthenticated users (`wp_ajax_nopriv_*`) that fail to implement proper `current_user_can()` authorization checks. While these handlers use ACF's `acf_verify_ajax()` function to validate cryptographic nonces, the `acf_nonce` values are generated for guest users and publicly exposed in the page source of any frontend page utilizing an ACF form. This makes it possible for unauthenticated attackers to extract the guest nonce and bypass WordPress visibility permissions, leading to the unauthorized disclosure of post titles and internal Flexible Content layout structures. The vulnerability was partially patched in version 0.9.2.4.

Description from the CVE record, published by Wordfence (the CVE Numbering Authority), via the NVD entry for CVE-2026-2839.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit