symfony/process security advisory
CVE-2026-24739: Symfony's incorrect argument escaping under MSYS2/Git Bash can lead to destructive file operations on Windows
CVE-2026-24739 is a medium-severity security vulnerability in the PHP package symfony/process (CVSS 6.3), published 28 January 2026. It is fixed in 5.4.51, 6.4.33, 7.3.11, 7.4.5 and 8.0.5, one per release line; earlier versions on each line are affected. It can be exploited without an account.
medium 6.3 published 2026-01-28 · updated 2026-06-17
- Affected versions
- < 5.4.51
>= 6.4, < 6.4.33
>= 7.3, < 7.3.11
>= 7.4, < 7.4.5
>= 8.0, < 8.0.5 - Fixed in
- 5.4.51, 6.4.33, 7.3.11, 7.4.5, 8.0.5
- Newest release
- 8.1.10
- Severity
- Medium · CVSS 6.3
- Type
- Security issue
CWE-88 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Also affects
- symfony/symfony < 5.4.51; >= 6.4, < 6.4.33; >= 7.3, < 7.3.11; >= 7.4, < 7.4.5; >= 8.0, < 8.0.5 fixed in 5.4.51, 6.4.33, 7.3.11, 7.4.5, 8.0.5
Is your symfony/process version affected?
Who can exploit CVE-2026-24739
- Access: No account. Anyone who can send a request to an app that uses the affected code.
- Interaction: A user also has to do something, such as open a link or a page the attacker prepared.
- Position: The attacker needs local access to the server.
- Conditions: It only works under specific conditions the attacker does not fully control (CVSS rates the attack as high complexity).
CVSS vector (scored by GitHub): CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:H
How to fix CVE-2026-24739 in symfony/process
- Find the installed version:
composer show symfony/process. If you never required it yourself,composer why symfony/processshows which package pulls it in. - Update it:
composer update symfony/process --with-all-dependencies. You need the fixed version for your release line (5.4.51, 6.4.33, 7.3.11, 7.4.5 and 8.0.5). - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"symfony/process": "^8.0.5"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-24739. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
The advisory gives this workaround:
Some workarounds are available.
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-24739 advisory
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to versions 5.4.51, 6.4.33, 7.3.11, 7.4.5, and 8.0.5, the Symfony Process component did not correctly treat some characters (notably `=`) as “special” when escaping arguments on Windows. When PHP is executed from an MSYS2-based environment (e.g. Git Bash) and Symfony Process spawns native Windows executables, MSYS2’s argument/path conversion can mis-handle unquoted arguments containing these characters. This can cause the spawned process to receive corrupted/truncated arguments compared to what Symfony intended. If an application (or tooling such as Composer scripts) uses Symfony Process to invoke file-management commands (e.g. `rmdir`, `del`, etc.) with a path argument containing `=`, the MSYS2 conversion layer may alter the argument at runtime. In affected setups this can result in operations being performed on an unintended path, up to and including deletion of the contents of a broader directory or drive. The issue is particularly relevant when untrusted input can influence process arguments (directly or indirectly, e.g. via repository paths, extracted archive paths, temporary directories, or user-controlled configuration). Versions 5.4.51, 6.4.33, 7.3.11, 7.4.5, and 8.0.5 contains a patch for the issue. Some workarounds are available. Avoid running PHP/one's own tooling from MSYS2-based shells on Windows; prefer cmd.exe or PowerShell for workflows that spawn native executables. Avoid passing paths containing `=` (and similar MSYS2-sensitive characters) to Symfony Process when operating under Git Bash/MSYS2. Where applicable, configure MSYS2 to disable or restrict argument conversion (e.g. via `MSYS2_ARG_CONV_EXCL`), understanding this may affect other tooling behavior.
References
- GitHub advisory GHSA-r39x-jcww-82v6 github.com
- Fix commit 3520393 github.com
- Fix commit ec154f6 github.com
- Pull request #63164 github.com
- github.com github.com
Other symfony/process advisories
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.