Skip to content
Laskyr

CVE-2026-118638: Mapster WP Maps missing authorization check vulnerability

high 7.5 published 2026-10-31 · updated 2026-11-02

Fixed in Mapster WP Maps 2.0.6

Mapster WP Maps older than 2.0.6 is affected by this missing authorization issue. Sites on 2.0.6 or newer are not affected; the latest release is 2.0.6.

Affected versions
older than 2.0.6
Fixed in
2.0.6
Latest version
2.0.6
Severity
High · CVSS 7.5
Active installs
3,000+
Type
Missing authorization check

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

What to do now

  1. Update Mapster WP Maps to 2.0.6 or newer: Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Mapster WP Maps issue. With WP-CLI: wp plugin get mapster-wp-maps --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Mapster WP Maps WordPress plugin before 2.0.6 does not perform any authorization check on a REST API route that writes post data, allowing unauthenticated attackers to overwrite the title of arbitrary posts, create arbitrary published posts, and overwrite the Mapster WP Maps WordPress plugin before 2.0.6's stored settings.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-118638.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit