Skip to content
Laskyr

CVE-2026-118090: MasterStudy LMS WordPress Plugin PHP object injection vulnerability

high 8.8 published 2026-10-30

Fixed in MasterStudy LMS WordPress Plugin 3.7.56

MasterStudy LMS WordPress Plugin 3.7.55 and older is affected by this PHP object injection issue. Sites on 3.7.56 or newer are not affected; the latest release is 3.7.58.

Affected versions
3.7.55 and older
Fixed in
3.7.56
Latest version
3.7.58
Severity
High · CVSS 8.8
Active installs
10,000+
Type
PHP object injection

What an attacker needs

CVSS vector (score by Patchstack): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

What to do now

  1. Update MasterStudy LMS WordPress Plugin to 3.7.56 or newer (the latest is 3.7.58): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known MasterStudy LMS WordPress Plugin issue. With WP-CLI: wp plugin get masterstudy-lms-learning-management-system --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

Subscriber PHP Object Injection in MasterStudy LMS <= 3.7.55 versions.

Description from the CVE record, published by Patchstack (the CVE Numbering Authority), via the NVD entry for CVE-2026-118090.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit