Skip to content
Laskyr

CVE-2026-118081: 10WebSocial PHP object injection vulnerability

high 8.8 published 2026-10-29

The record does not say which version fixes it

10WebSocial 1.5.6 and older is affected by this PHP object injection issue. Keep 10WebSocial on the latest version (1.4.35) and check the advisory below.

Note: part of the source's version range goes past the newest 10WebSocial release on wordpress.org (1.4.35), so it probably describes a paid edition with its own version numbers, or contains a typo. We do not use that part to judge versions.

Affected versions
1.5.6 and older
Fixed in
unknown
Latest version
1.4.35
Severity
High · CVSS 8.8
Active installs
10,000+
Type
PHP object injection

What an attacker needs

CVSS vector (score by Patchstack): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

What to do now

  1. Update 10WebSocial to the latest version (1.4.35). The record does not name a fixed version, so also read the advisory below.
  2. If you cannot update right away, deactivate it until you can.
  3. Not sure which version you run? Check your version against every known 10WebSocial issue. With WP-CLI: wp plugin get wd-instagram-feed --field=version.
  4. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

Contributor PHP Object Injection in 10Web Social Photo Feed <= 1.5.6 versions.

Description from the CVE record, published by Patchstack (the CVE Numbering Authority), via the NVD entry for CVE-2026-118081.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit