Skip to content
Laskyr

CVE-2026-115807: User Profile Builder privilege escalation vulnerability

high 7.1 published 2026-10-24 · updated 2026-10-29

Fixed in User Profile Builder 4.0.4 (first release after the affected range)

User Profile Builder 4.0.3 and older is affected by this privilege escalation issue. Sites on 4.0.4 or newer are not affected; the latest release is 4.0.6.

Affected versions
4.0.3 and older
Fixed in
4.0.4 *
Latest version
4.0.6
Severity
High · CVSS 7.1
Active installs
40,000+
Type
Privilege escalation

* The source does not name a fixed version; this is the first wordpress.org release after the last affected version.

What an attacker needs

CVSS vector (score by Wordfence): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N

What to do now

  1. Update User Profile Builder to 4.0.4 or newer (the latest is 4.0.6): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known User Profile Builder issue. With WP-CLI: wp plugin get profile-builder --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The User Profile Builder – Beautiful User Registration Forms, User Profiles & User Role Editor plugin for WordPress is vulnerable to Limited Privilege Escalation in all versions up to, and including, 4.0.3. This is due to the Gutenberg Register block passing the attacker-controlled Assigned Role attribute directly into the `[wppb-register]` shortcode without server-side authorization. The role guard in the form builder only downgrades roles that carry the manage_options or remove_users capability, leaving the Editor role and other privileged non-Administrator roles completely unrestricted. This makes it possible for authenticated attackers with Author-level access and above to create new WordPress accounts bearing the Editor role (or any other role that lacks the two guarded capabilities).

Description from the CVE record, published by Wordfence (the CVE Numbering Authority), via the NVD entry for CVE-2026-115807.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit