CVE-2026-114422: Enable Media Replace PHP object injection vulnerability
high 7.5 published 2026-10-30
- Affected versions
- 4.1.4 up to (not including) 4.2.3
- Fixed in
- 4.2.3
- Latest version
- 4.2.3
- Severity
- High · CVSS 7.5
- Active installs
- 600,000+
- Type
- PHP object injection
What an attacker needs
- Access: None. No account or login is needed.
- Interaction: It also needs someone on the site (often an admin) to click a link, open a page or submit a form the attacker prepared.
CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
What to do now
- Update Enable Media Replace to 4.2.3 or newer: Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- Not sure which version you run? Check your version against every known Enable Media Replace issue.
With WP-CLI:
wp plugin get enable-media-replace --field=version. - If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.
The advisory
The Enable Media Replace WordPress plugin before 4.2.3 does not restrict the classes allowed when deserializing stored metadata during its media replace-and-update-links routine, allowing unauthenticated users to inject a PHP object that is instantiated when a user with upload access performs a routine media replacement, resulting in PHP Object Injection and local file inclusion of existing PHP/HTML files, which can be escalated to remote code execution where an attacker-influenced PHP or HTML file is present on the server. This is a regression of CVE-2023-4643, which was fixed in 4.1.3 and reintroduced in 4.1.4.
References
- NVD CVE-2026-114422 nvd.nist.gov
- WPScan advisory wpscan.com
Related
Ran an affected version? Check your site for signs of a hack
The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.
Where this data comes from
- CVE record, score and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Versions and install counts: wordpress.org/plugins/enable-media-replace (Plugins API), fetched 2026-11-01.
- The summary, “what an attacker needs” and “what to do” sections are our plain-English reading of the record and the plugin's release history; the quoted description is the record's own text. Spot an error? Email Daniel.