Skip to content
Laskyr

CVE-2026-113482: Media Library Assistant stored cross-site scripting (XSS) vulnerability

medium 6.8 published 2026-11-01 · updated 2026-11-02

Fixed in Media Library Assistant 3.44

Media Library Assistant older than 3.44 is affected by this stored XSS issue. Sites on 3.44 or newer are not affected; the latest release is 3.44.

Affected versions
older than 3.44
Fixed in
3.44
Latest version
3.44
Severity
Medium · CVSS 6.8
Active installs
70,000+
Type
Stored cross-site scripting (XSS)

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H

What to do now

  1. Update Media Library Assistant to 3.44 or newer: Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Media Library Assistant issue. With WP-CLI: wp plugin get media-library-assistant --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Media Library Assistant WordPress plugin before 3.44 does not escape one of its shortcode attributes before outputting it in an attribute of generated links, allowing users with the Contributor role and above to perform Stored Cross-Site Scripting attacks.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-113482.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit