Skip to content
Laskyr

CVE-2026-112313: Advanced Custom Fields stored cross-site scripting (XSS) vulnerability

high 7.1 published 2026-10-22

Fixed in Advanced Custom Fields 0.9.2.8

Advanced Custom Fields 0.9.2.7 and older is affected by this stored XSS issue. Sites on 0.9.2.8 or newer are not affected; the latest release is 0.9.2.8.

Affected versions
0.9.2.7 and older
Fixed in
0.9.2.8
Latest version
0.9.2.8
Severity
High · CVSS 7.1
Active installs
100,000+
Type
Stored cross-site scripting (XSS)

What an attacker needs

CVSS vector (score by Patchstack): CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L

What to do now

  1. Update Advanced Custom Fields to 0.9.2.8 or newer: Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Advanced Custom Fields issue. With WP-CLI: wp plugin get acf-extended --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ACF Extended ACF Extended acf-extended allows Stored XSS.This issue affects ACF Extended: from n/a through 0.9.2.7.

Description from the CVE record, published by Patchstack (the CVE Numbering Authority), via the NVD entry for CVE-2026-112313.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit