Skip to content
Laskyr

CVE-2026-111949: miniOrange 2FA authentication bypass vulnerability

high 7.5 published 2026-10-21

Fixed in miniOrange 2FA 6.3.1

miniOrange 2FA 6.2.9 up to (not including) 6.3.1 is affected by this authentication bypass issue. Sites on 6.3.1 or newer are not affected; the latest release is 6.6.0.

Affected versions
6.2.9 up to (not including) 6.3.1
Fixed in
6.3.1
Latest version
6.6.0
Severity
High · CVSS 7.5
Active installs
10,000+
Type
Authentication bypass

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

What to do now

  1. Update miniOrange 2FA to 6.3.1 or newer (the latest is 6.6.0): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known miniOrange 2FA issue. With WP-CLI: wp plugin get miniorange-2-factor-authentication --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The miniOrange 2FA WordPress plugin before 6.3.1 does not prevent a pending passkey login from registering an additional passkey on an account that already has one configured, allowing an attacker who knows a user's password to add their own authenticator and bypass the second factor.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-111949.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit