Skip to content
Laskyr

CVE-2026-111850: BuddyPress SQL injection vulnerability

high 8.5 published 2026-10-28 · updated 2026-10-29

Fixed in BuddyPress 14.5.3

BuddyPress 14.5.2 and older is affected by this SQL injection issue. Sites on 14.5.3 or newer are not affected; the latest release is 14.5.4.

Affected versions
14.5.2 and older
Fixed in
14.5.3
Latest version
14.5.4
Severity
High · CVSS 8.5
Active installs
90,000+
Type
SQL injection

What an attacker needs

CVSS vector (score by Patchstack): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:L

What to do now

  1. Update BuddyPress to 14.5.3 or newer (the latest is 14.5.4): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known BuddyPress issue. With WP-CLI: wp plugin get buddypress --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in BuddyPress BuddyPress buddypress allows SQL Injection.This issue affects BuddyPress: from n/a through 14.5.2.

Description from the CVE record, published by Patchstack (the CVE Numbering Authority), via the NVD entry for CVE-2026-111850.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit