Skip to content
Laskyr

CVE-2026-111841: FunnelKit Automations cross-site request forgery (CSRF) vulnerability

high 8.8 published 2026-10-26

Fixed in FunnelKit Automations 3.8.6

FunnelKit Automations 3.8.5.2 and older is affected by this CSRF issue. Sites on 3.8.6 or newer are not affected; the latest release is 3.9.0.

Affected versions
3.8.5.2 and older
Fixed in
3.8.6
Latest version
3.9.0
Severity
High · CVSS 8.8
Active installs
20,000+
Type
Cross-site request forgery (CSRF)

What an attacker needs

CVSS vector (score by Patchstack): CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

What to do now

  1. Update FunnelKit Automations to 3.8.6 or newer (the latest is 3.9.0): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known FunnelKit Automations issue. With WP-CLI: wp plugin get wp-marketing-automations --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

Cross-Site Request Forgery (CSRF) vulnerability in Aman FunnelKit Automations wp-marketing-automations allows Cross Site Request Forgery.This issue affects FunnelKit Automations: from n/a through 3.8.5.2.

Description from the CVE record, published by Patchstack (the CVE Numbering Authority), via the NVD entry for CVE-2026-111841.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit