Skip to content
Laskyr

CVE-2026-111832: WP Mailster arbitrary file upload vulnerability

critical 10.0 published 2026-10-21

Fixed in WP Mailster 1.9.2.0

WP Mailster 1.9.1.0 and older is affected by this arbitrary file upload issue. Sites on 1.9.2.0 or newer are not affected; the latest release is 1.9.2.0.

Affected versions
1.9.1.0 and older
Fixed in
1.9.2.0
Latest version
1.9.2.0
Severity
Critical · CVSS 10.0
Active installs
300+
Type
Arbitrary file upload

What an attacker needs

CVSS vector (score by Patchstack): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

What to do now

  1. Update WP Mailster to 1.9.2.0 or newer: Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known WP Mailster issue. With WP-CLI: wp plugin get wp-mailster --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

Unrestricted Upload of File with Dangerous Type vulnerability in WP Mailster WP Mailster wp-mailster allows Upload a Web Shell to a Web Server.This issue affects WP Mailster: from n/a through 1.9.1.0.

Description from the CVE record, published by Patchstack (the CVE Numbering Authority), via the NVD entry for CVE-2026-111832.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit