Skip to content
Laskyr

CVE-2026-111577: GoSMTP privilege escalation vulnerability

high 7.2 published 2026-10-28

Fixed in GoSMTP 1.2.5

GoSMTP older than 1.2.5 is affected by this privilege escalation issue. Sites on 1.2.5 or newer are not affected; the latest release is 1.2.5.

Affected versions
older than 1.2.5
Fixed in
1.2.5
Latest version
1.2.5
Severity
High · CVSS 7.2
Active installs
500,000+
Type
Privilege escalation

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

What to do now

  1. Update GoSMTP to 1.2.5 or newer: Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known GoSMTP issue. With WP-CLI: wp plugin get gosmtp --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The GoSMTP WordPress plugin before 1.2.5 does not perform a settings-management authorization check on its SMTP configuration page, which is gated only on the GoSMTP WordPress plugin before 1.2.5-activation capability, allowing users with a delegated role below administrator to change outbound mail delivery and achieve administrator account takeover.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-111577.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit