Skip to content
Laskyr

CVE-2026-111041: AI Engine missing authorization check vulnerability

medium 4.9 published 2026-10-18 · updated 2026-10-19

Fixed in AI Engine 3.7.9

AI Engine older than 3.7.9 is affected by this missing authorization issue. Sites on 3.7.9 or newer are not affected; the latest release is 3.9.0.

Affected versions
older than 3.7.9
Fixed in
3.7.9
Latest version
3.9.0
Severity
Medium · CVSS 4.9
Active installs
90,000+
Type
Missing authorization check

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N

What to do now

  1. Update AI Engine to 3.7.9 or newer (the latest is 3.9.0): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known AI Engine issue. With WP-CLI: wp plugin get ai-engine --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The AI Engine WordPress plugin before 3.7.9 does not verify that the user performing certain AI media management actions owns or is otherwise allowed to edit the targeted object, allowing users with the Editor role or above to modify, or change the type of, arbitrary posts on the site, including content they are not permitted to edit.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-111041.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit