Skip to content
Laskyr

CVE-2026-111031: Welcart e-Commerce open redirect vulnerability

medium 4.7 published 2026-10-28

Fixed in Welcart e-Commerce 2.12.6

Welcart e-Commerce older than 2.12.6 is affected by this open redirect issue. Sites on 2.12.6 or newer are not affected; the latest release is 2.12.7.

Affected versions
older than 2.12.6
Fixed in
2.12.6
Latest version
2.12.7
Severity
Medium · CVSS 4.7
Active installs
10,000+
Type
Open redirect

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N

What to do now

  1. Update Welcart e-Commerce to 2.12.6 or newer (the latest is 2.12.7): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Welcart e-Commerce issue. With WP-CLI: wp plugin get usc-e-shop --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Welcart e-Commerce WordPress plugin before 2.12.6 does not validate a user-supplied URL before using it in a redirect, allowing unauthenticated attackers to redirect users to arbitrary external websites.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-111031.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit