Skip to content
Laskyr

CVE-2026-110898: Essential Addons for Elementor privilege escalation vulnerability

medium 6.4 published 2026-10-19

Fixed in Essential Addons for Elementor 6.8.6

Essential Addons for Elementor 6.8.5 and older is affected by this privilege escalation issue. Sites on 6.8.6 or newer are not affected; the latest release is 6.8.8.

Affected versions
6.8.5 and older
Fixed in
6.8.6
Latest version
6.8.8
Severity
Medium · CVSS 6.4
Active installs
1+ million
Type
Privilege escalation

What an attacker needs

CVSS vector (score by Patchstack): CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H

What to do now

  1. Update Essential Addons for Elementor to 6.8.6 or newer (the latest is 6.8.8): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Essential Addons for Elementor issue. With WP-CLI: wp plugin get essential-addons-for-elementor-lite --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

Incorrect Privilege Assignment vulnerability in WPDeveloper Essential Addons for Elementor essential-addons-for-elementor-lite allows Privilege Escalation.This issue affects Essential Addons for Elementor: from n/a through 6.8.5.

Description from the CVE record, published by Patchstack (the CVE Numbering Authority), via the NVD entry for CVE-2026-110898.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit