CVE-2026-110808: Essential Addons for Elementor privilege escalation vulnerability
medium 4.2 published 2026-10-31 · updated 2026-11-02
- Affected versions
- 6.6.0 up to (not including) 6.8.8
- Fixed in
- 6.8.8
- Latest version
- 6.8.8
- Severity
- Medium · CVSS 4.2
- Active installs
- 1+ million
- Type
- Privilege escalation
What an attacker needs
- Access: None. No account or login is needed.
- Interaction: It also needs someone on the site (often an admin) to click a link, open a page or submit a form the attacker prepared.
CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:N
What to do now
- Update Essential Addons for Elementor to 6.8.8 or newer: Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- Not sure which version you run? Check your version against every known Essential Addons for Elementor issue.
With WP-CLI:
wp plugin get essential-addons-for-elementor-lite --field=version. - If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.
The advisory
The Essential Addons for Elementor WordPress plugin before 6.8.8 does not correctly restrict who may set the role assigned to accounts created through its registration form, allowing authenticated users with Author-level access and above to cause newly registered accounts, including those created by unauthenticated visitors through the public registration form, to be granted a higher role such as Editor. This is an incomplete fix of CVE-2026-5193: the role-validation control added in 6.6.0 can be circumvented by a lower-privileged user, so versions 6.6.0 through 6.8.7 remain affected even on sites that are patched against that advisory.
References
- NVD CVE-2026-110808 nvd.nist.gov
- WPScan advisory wpscan.com
Related
Ran an affected version? Check your site for signs of a hack
The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.
Where this data comes from
- CVE record, score and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Versions and install counts: wordpress.org/plugins/essential-addons-for-elementor-lite (Plugins API), fetched 2026-11-01.
- The summary, “what an attacker needs” and “what to do” sections are our plain-English reading of the record and the plugin's release history; the quoted description is the record's own text. Spot an error? Email Daniel.