Skip to content
Laskyr

CVE-2026-110510: Essential Addons for Elementor vulnerability

low 3.5 published 2026-10-23

Fixed in Essential Addons for Elementor 6.8.7

Essential Addons for Elementor older than 6.8.7 is affected by this security issue. Sites on 6.8.7 or newer are not affected; the latest release is 6.8.8.

Affected versions
older than 6.8.7
Fixed in
6.8.7
Latest version
6.8.8
Severity
Low · CVSS 3.5
Active installs
1+ million
Type
Security issue

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N

What to do now

  1. Update Essential Addons for Elementor to 6.8.7 or newer (the latest is 6.8.8): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Essential Addons for Elementor issue. With WP-CLI: wp plugin get essential-addons-for-elementor-lite --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Essential Addons for Elementor WordPress plugin before 6.8.7 does not validate the HTML tag setting of some of its widgets before using it to build markup, which could allow users with the author role and above to inject iframe and form elements into published pages.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-110510.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit