Skip to content
Laskyr

CVE-2026-109933: Otter Blocks cross-site scripting (XSS) vulnerability

medium 6.8 published 2026-10-23

Fixed in Otter Blocks 3.2.8

Otter Blocks older than 3.2.8 is affected by this XSS issue. Sites on 3.2.8 or newer are not affected; the latest release is 3.2.8.

Affected versions
older than 3.2.8
Fixed in
3.2.8
Latest version
3.2.8
Severity
Medium · CVSS 6.8
Active installs
300,000+
Type
Cross-site scripting (XSS)

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H

What to do now

  1. Update Otter Blocks to 3.2.8 or newer: Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Otter Blocks issue. With WP-CLI: wp plugin get otter-blocks --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Otter Blocks WordPress plugin before 3.2.8 does not properly sanitize and escape user-supplied block styling values before writing them into an inline stylesheet, allowing users with contributor-level access and above to inject arbitrary web scripts that execute when any visitor, including administrators, views the affected post.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-109933.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit