Skip to content
Laskyr

CVE-2026-109931: Infility Global missing authorization check vulnerability

low 3.7 published 2026-10-22

Fixed in Infility Global 2.16.25

Infility Global older than 2.16.25 is affected by this missing authorization issue. Sites on 2.16.25 or newer are not affected; the latest release is 2.16.27.

Affected versions
older than 2.16.25
Fixed in
2.16.25
Latest version
2.16.27
Severity
Low · CVSS 3.7
Active installs
100+
Type
Missing authorization check

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

What to do now

  1. Update Infility Global to 2.16.25 or newer (the latest is 2.16.27): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Infility Global issue. With WP-CLI: wp plugin get infility-global --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Infility Global WordPress plugin before 2.16.25 does not perform any authorisation or nonce check on an AJAX action available to unauthenticated users, allowing any visitor to overwrite a machine-translation configuration value belonging to a companion Infility Global WordPress plugin before 2.16.25.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-109931.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit