Skip to content
Laskyr

CVE-2026-109369: WP Booking System missing authorization check vulnerability

medium 6.8 published 2026-10-17 · updated 2026-10-19

Fixed in WP Booking System 2.1.0.4 (first release after the affected range)

WP Booking System 2.1.0.3 and older is affected by this missing authorization issue. Sites on 2.1.0.4 or newer are not affected; the latest release is 2.1.0.7.

Affected versions
2.1.0.3 and older
Fixed in
2.1.0.4 *
Latest version
2.1.0.7
Severity
Medium · CVSS 6.8
Active installs
10,000+
Type
Missing authorization check

* The source does not name a fixed version; this is the first wordpress.org release after the last affected version.

What an attacker needs

CVSS vector (score by Wordfence): CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N

What to do now

  1. Update WP Booking System to 2.1.0.4 or newer (the latest is 2.1.0.7): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known WP Booking System issue. With WP-CLI: wp plugin get wp-booking-system --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The WP Booking System – Booking Calendar plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 2.1.0.3 This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with subscriber-level access and above, to grant themselves and arbitrary other users edit access to every booking form on the site by overwriting the user_permission meta that governs the plugin's own access-control list. Exploitation requires the attacker to have already been delegated edit rights on at least one booking form, as this delegation both downgrades the submenu capability to 'read' (making the edit page accessible) and allows them to harvest a valid wpbs_edit_form nonce that will pass validation against any other form_id.

Description from the CVE record, published by Wordfence (the CVE Numbering Authority), via the NVD entry for CVE-2026-109369.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit