CVE-2026-107645: Blocksy Companion privilege escalation vulnerability
critical 9.1 published 2026-10-10 · updated 2026-10-13
- Affected versions
- 2.1.58 and older
- Fixed in
- 2.1.59 *
- Latest version
- 2.1.61
- Severity
- Critical · CVSS 9.1
- Active installs
- 300,000+
- Type
- Privilege escalation
* The source does not name a fixed version; this is the first wordpress.org release after the last affected version.
What an attacker needs
- Access: None. No account or login is needed.
CVSS vector (score by Wordfence): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
What to do now
- Update Blocksy Companion to 2.1.59 or newer (the latest is 2.1.61): Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- Not sure which version you run? Check your version against every known Blocksy Companion issue.
With WP-CLI:
wp plugin get blocksy-companion --field=version. - If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.
The advisory
The Blocksy Companion plugin for WordPress is vulnerable to privilege escalation in versions up to, and including, 2.1.58 This is due to the implement_user_registration() AJAX handler explicitly disabling Dokan's vendor-registration nonce check (via add_filter('dokan_register_nonce_check', '__return_false')) and then trusting an attacker-supplied $_POST['role'] value when invoking wc_create_new_customer() and wc_set_customer_auth_cookie(). This makes it possible for unauthenticated attackers to elevate their privileges to a Dokan 'seller' (vendor) account — including sites where the Dokan vendor signup is explicitly turned off — and to be auto-authenticated into that account, which grants publishing capabilities beyond those of a normal customer.
References
- NVD CVE-2026-107645 nvd.nist.gov
- Wordfence advisory www.wordfence.com
- Code change (fix) plugins.trac.wordpress.org
- Plugin source plugins.trac.wordpress.org
Related
Ran an affected version? Check your site for signs of a hack
The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.
Where this data comes from
- CVE record, score and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Versions and install counts: wordpress.org/plugins/blocksy-companion (Plugins API), fetched 2026-11-01.
- The summary, “what an attacker needs” and “what to do” sections are our plain-English reading of the record and the plugin's release history; the quoted description is the record's own text. Spot an error? Email Daniel.