Skip to content
Laskyr

CVE-2026-107447: Contest Gallery vulnerability

medium 5.3 published 2026-10-21

Fixed in Contest Gallery 34.0.1

Contest Gallery older than 34.0.1 is affected by this security issue. Sites on 34.0.1 or newer are not affected; the latest release is 34.0.3.

Affected versions
older than 34.0.1
Fixed in
34.0.1
Latest version
34.0.3
Severity
Medium · CVSS 5.3
Active installs
1,000+
Type
Security issue

What an attacker needs

CVSS vector (score by WPScan): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

What to do now

  1. Update Contest Gallery to 34.0.1 or newer (the latest is 34.0.3): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Contest Gallery issue. With WP-CLI: wp plugin get contest-gallery --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Contest Gallery WordPress plugin before 34.0.1 does not reliably validate the visitor identity used to enforce its one-vote-per-entry restriction, trusting a client-supplied request header and an unbound client-generated token, which allows unauthenticated users to bypass the restriction and cast multiple votes for the same contest entry, inflating its vote total.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-107447.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit