Skip to content
Laskyr

CVE-2026-107424: Frontend Dashboard privilege escalation vulnerability

critical 9.8 published 2026-10-14

Fixed in Frontend Dashboard 3.0.8

Frontend Dashboard 3.0.7 and older is affected by this privilege escalation issue. Sites on 3.0.8 or newer are not affected; the latest release is 3.1.1.

Affected versions
3.0.7 and older
Fixed in
3.0.8
Latest version
3.1.1
Severity
Critical · CVSS 9.8
Active installs
400+
Type
Privilege escalation

What an attacker needs

CVSS vector (score by Patchstack): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

What to do now

  1. Update Frontend Dashboard to 3.0.8 or newer (the latest is 3.1.1): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Frontend Dashboard issue. With WP-CLI: wp plugin get frontend-dashboard --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

Incorrect Privilege Assignment vulnerability in M A Vinoth Kumar Frontend Dashboard frontend-dashboard allows Privilege Escalation.This issue affects Frontend Dashboard: from n/a through 3.0.7.

Description from the CVE record, published by Patchstack (the CVE Numbering Authority), via the NVD entry for CVE-2026-107424.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit