Skip to content
Laskyr

CVE-2026-107420: Pay With MetaMask For WooCommerce vulnerability

medium 5.3 published 2026-10-10 · updated 2026-10-13

Fixed in Pay With MetaMask For WooCommerce 1.7.3

Pay With MetaMask For WooCommerce 1.7.2 and older is affected by this security issue. Sites on 1.7.3 or newer are not affected; the latest release is 1.7.3.

Affected versions
1.7.2 and older
Fixed in
1.7.3
Latest version
1.7.3
Severity
Medium · CVSS 5.3
Active installs
400+
Type
Security issue

What an attacker needs

CVSS vector (score by Patchstack): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

What to do now

  1. Update Pay With MetaMask For WooCommerce to 1.7.3 or newer: Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Pay With MetaMask For WooCommerce issue. With WP-CLI: wp plugin get cryptocurrency-payments-using-metamask-for-woocommerce --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

Unauthenticated Bypass Vulnerability in Pay With MetaMask For WooCommerce – Cryptocurrency Payment Gateway <= 1.7.2 versions.

Description from the CVE record, published by Patchstack (the CVE Numbering Authority), via the NVD entry for CVE-2026-107420.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit