Skip to content
Laskyr

CVE-2026-106608: WooCommerce privilege escalation vulnerability

high 7.2 published 2026-10-10 · updated 2026-10-13

Fixed in WooCommerce 11.2.0

WooCommerce 9.8.0 to 11.1.2 is affected by this privilege escalation issue. Sites on 11.2.0 or newer are not affected; the latest release is 11.2.1.

Affected versions
9.8.0 to 11.1.2
Fixed in
11.2.0
Latest version
11.2.1
Severity
High · CVSS 7.2
Active installs
7+ million
Type
Privilege escalation

What an attacker needs

CVSS vector (score by Patchstack): CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

What to do now

  1. Update WooCommerce to 11.2.0 or newer (the latest is 11.2.1): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known WooCommerce issue. With WP-CLI: wp plugin get woocommerce --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

Incorrect Privilege Assignment vulnerability in Automattic WooCommerce woocommerce allows Privilege Escalation.This issue affects WooCommerce: from 9.8.0 through 11.1.2.

Description from the CVE record, published by Patchstack (the CVE Numbering Authority), via the NVD entry for CVE-2026-106608.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit