Skip to content
Laskyr

CVE-2026-106470: WP Data Access cross-site request forgery (CSRF) vulnerability

medium 5.0 published 2026-10-17 · updated 2026-10-19

Fixed in WP Data Access 5.5.88

WP Data Access older than 5.5.88 is affected by this CSRF issue. Sites on 5.5.88 or newer are not affected; the latest release is 5.5.90.

Affected versions
older than 5.5.88
Fixed in
5.5.88
Latest version
5.5.90
Severity
Medium · CVSS 5.0
Active installs
10,000+
Type
Cross-site request forgery (CSRF)

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N

What to do now

  1. Update WP Data Access to 5.5.88 or newer (the latest is 5.5.90): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known WP Data Access issue. With WP-CLI: wp plugin get wp-data-access --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The WP Data Access WordPress plugin before 5.5.88 does not have authorisation and CSRF checks in one of its actions, allowing any authenticated user, such as a subscriber, to make the server open connections to arbitrary hosts and ports, including internal ones, and read back the outcome.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-106470.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit