Skip to content
Laskyr

CVE-2026-106003: Court Reservation missing authorization check vulnerability

medium 5.3 published 2026-10-28

Fixed in Court Reservation 1.12.4

Court Reservation older than 1.12.4 is affected by this missing authorization issue. Sites on 1.12.4 or newer are not affected; the latest release is 1.12.4.

Affected versions
older than 1.12.4
Fixed in
1.12.4
Latest version
1.12.4
Severity
Medium · CVSS 5.3
Active installs
90+
Type
Missing authorization check

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

What to do now

  1. Update Court Reservation to 1.12.4 or newer: Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Court Reservation issue. With WP-CLI: wp plugin get court-reservation --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Court Reservation WordPress plugin before 1.12.4 does not perform any authorization, authentication or nonce validation on one of its AJAX actions, allowing unauthenticated users to add or delete reservation types in the Court Reservation WordPress plugin before 1.12.4's configuration.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-106003.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit