Skip to content
Laskyr

CVE-2026-105996: Booking Package vulnerability

medium 4.8 published 2026-10-21

Fixed in Booking Package 1.7.31

Booking Package older than 1.7.31 is affected by this security issue. Sites on 1.7.31 or newer are not affected; the latest release is 1.7.41.

Affected versions
older than 1.7.31
Fixed in
1.7.31
Latest version
1.7.41
Severity
Medium · CVSS 4.8
Active installs
10,000+
Type
Security issue

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

What to do now

  1. Update Booking Package to 1.7.31 or newer (the latest is 1.7.41): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Booking Package issue. With WP-CLI: wp plugin get booking-package --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Booking Package WordPress plugin before 1.7.31 does not generate booking cancellation tokens using a secure source of randomness, deriving them instead from values it exposes publicly, so an unauthenticated attacker can reconstruct an arbitrary booking's token, disclose that booking's personal data and, where visitor cancellation is enabled, cancel the booking.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-105996.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit