Skip to content
Laskyr

CVE-2026-105193: Booking Calendar vulnerability

medium 4.8 published 2026-10-08

Fixed in Booking Calendar 11.8

Booking Calendar older than 11.8 is affected by this security issue. Sites on 11.8 or newer are not affected; the latest release is 12.0.

Affected versions
older than 11.8
Fixed in
11.8
Latest version
12.0
Severity
Medium · CVSS 4.8
Active installs
40,000+
Type
Security issue

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

What to do now

  1. Update Booking Calendar to 11.8 or newer (the latest is 12.0): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Booking Calendar issue. With WP-CLI: wp plugin get booking --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Booking Calendar WordPress plugin before 11.8 does not generate its per-booking access hashes with sufficient entropy, deriving each from a low-entropy time-seeded value, which can allow unauthenticated attackers who are able to determine a booking's creation time to predict the hash and then read that booking's personal data or modify the booking in place.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-105193.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit