Skip to content
Laskyr

CVE-2026-104798: My Calendar privilege escalation vulnerability

critical 9.8 published 2026-10-16

Fixed in My Calendar 3.8.11 (first release after the affected range)

My Calendar 3.4.24 and older, 3.5 to 3.5.21, 3.6 to 3.6.17, 3.7 to 3.7.17, 3.8 to 3.8.7 are affected by this privilege escalation issue. Sites on 3.8.11 or newer are not affected; the latest release is 3.8.12.

Affected versions
3.4.24 and older, 3.5 to 3.5.21, 3.6 to 3.6.17, 3.7 to 3.7.17, 3.8 to 3.8.7
Fixed in
3.8.11 *
Latest version
3.8.12
Severity
Critical · CVSS 9.8
Active installs
20,000+
Type
Privilege escalation

* The source does not name a fixed version; this is the first wordpress.org release after the last affected version.

What an attacker needs

CVSS vector (score by Wordfence): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

What to do now

  1. Update My Calendar to 3.8.11 or newer (the latest is 3.8.12): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known My Calendar issue. With WP-CLI: wp plugin get my-calendar --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The My Calendar – Accessible Event Manager plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 3.8.7. The public `mcs` GET parameter is reflected into post content unsanitized before WordPress core's `do_shortcode` filter runs, allowing an unauthenticated attacker to inject a nested `[my_calendar above=...]` shortcode; `mc_generate_calendar_nav()` then splits the `above` attribute on commas and dispatches each element via `call_user_func()` with no authentication, authorization, or callable allowlist check. This makes it possible for unauthenticated attackers to invoke arbitrary loaded PHP functions, enabling a call chain in which the shortcode `$params` array is passed to `edit_user()` — which PHP coerces to integer `1` as the `$user_id` argument — overwriting the credentials of the initial Administrator account (user ID 1) and granting the attacker full wp-admin access. Exploitation is trivially reachable via the plugin's auto-generated `/my-calendar/` page, which is publicly accessible by default upon plugin activation.

Description from the CVE record, published by Wordfence (the CVE Numbering Authority), via the NVD entry for CVE-2026-104798.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit