Skip to content
Laskyr

CVE-2026-104735: RSS Aggregator by Feedzy stored cross-site scripting (XSS) vulnerability

medium 6.4 published 2026-10-10 · updated 2026-10-13

Fixed in RSS Aggregator by Feedzy 5.2.11 (first release after the affected range)

RSS Aggregator by Feedzy 5.2.10 and older is affected by this stored XSS issue. Sites on 5.2.11 or newer are not affected; the latest release is 5.2.13.

Affected versions
5.2.10 and older
Fixed in
5.2.11 *
Latest version
5.2.13
Severity
Medium · CVSS 6.4
Active installs
40,000+
Type
Stored cross-site scripting (XSS)

* The source does not name a fixed version; this is the first wordpress.org release after the last affected version.

What an attacker needs

CVSS vector (score by Wordfence): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

What to do now

  1. Update RSS Aggregator by Feedzy to 5.2.11 or newer (the latest is 5.2.13): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known RSS Aggregator by Feedzy issue. With WP-CLI: wp plugin get feedzy-rss-feeds --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video Feeds Aggregator plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Feedzy Loop Block Feed URL / RSS <title> in all versions up to, and including, 5.2.10 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The payload is not neutralized at save time because post_content stores only a benign block reference to an external feed URL; the malicious HTML is injected at render time from the attacker-controlled RSS feed title, bypassing any save-time wp_kses filtering.

Description from the CVE record, published by Wordfence (the CVE Numbering Authority), via the NVD entry for CVE-2026-104735.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit