Skip to content
Laskyr

CVE-2026-104652: Envira Gallery cross-site scripting (XSS) vulnerability

medium 6.8 published 2026-10-07

Fixed in Envira Gallery 1.16.1

Envira Gallery older than 1.16.1 is affected by this XSS issue. Sites on 1.16.1 or newer are not affected; the latest release is 1.16.3.

Affected versions
older than 1.16.1
Fixed in
1.16.1
Latest version
1.16.3
Severity
Medium · CVSS 6.8
Active installs
100,000+
Type
Cross-site scripting (XSS)

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H

What to do now

  1. Update Envira Gallery to 1.16.1 or newer (the latest is 1.16.3): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Envira Gallery issue. With WP-CLI: wp plugin get envira-gallery-lite --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Envira Gallery WordPress plugin before 1.16.1 does not sanitise and escape a gallery item identifier before outputting it in an image tag attribute, allowing users with the Author role and above to inject arbitrary web scripts that execute when any visitor, including an administrator, views a page embedding the gallery.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-104652.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit