Skip to content
Laskyr

CVE-2026-104391: Quiz and Survey Master (QSM) stored cross-site scripting (XSS) vulnerability

medium 6.5 published 2026-10-07

Fixed in Quiz and Survey Master (QSM) 11.2.8

Quiz and Survey Master (QSM) 11.2.7 and older is affected by this stored XSS issue. Sites on 11.2.8 or newer are not affected; the latest release is 11.3.0.

Affected versions
11.2.7 and older
Fixed in
11.2.8
Latest version
11.3.0
Severity
Medium · CVSS 6.5
Active installs
40,000+
Type
Stored cross-site scripting (XSS)

What an attacker needs

CVSS vector (score by Patchstack): CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L

What to do now

  1. Update Quiz and Survey Master (QSM) to 11.2.8 or newer (the latest is 11.3.0): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Quiz and Survey Master (QSM) issue. With WP-CLI: wp plugin get quiz-master-next --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ExpressTech Quiz And Survey Master quiz-master-next allows Stored XSS.This issue affects Quiz And Survey Master: from n/a through 11.2.7.

Description from the CVE record, published by Patchstack (the CVE Numbering Authority), via the NVD entry for CVE-2026-104391.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit