Skip to content
Laskyr

CVE-2026-103897: Responsive Lightbox & Gallery stored cross-site scripting (XSS) vulnerability

medium 4.4 published 2026-10-10 · updated 2026-10-13

Fixed in Responsive Lightbox & Gallery 2.7.10 (first release after the affected range)

Responsive Lightbox & Gallery 2.7.9 and older is affected by this stored XSS issue. Sites on 2.7.10 or newer are not affected; the latest release is 2.7.11.1.

Affected versions
2.7.9 and older
Fixed in
2.7.10 *
Latest version
2.7.11.1
Severity
Medium · CVSS 4.4
Active installs
100,000+
Type
Stored cross-site scripting (XSS)

* The source does not name a fixed version; this is the first wordpress.org release after the last affected version.

What an attacker needs

CVSS vector (score by Wordfence): CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N

What to do now

  1. Update Responsive Lightbox & Gallery to 2.7.10 or newer (the latest is 2.7.11.1): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Responsive Lightbox & Gallery issue. With WP-CLI: wp plugin get responsive-lightbox --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Responsive Lightbox & Gallery plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 2.7.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with editor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires the plugin's 'Comments' lightbox setting to be enabled (disabled by default), a moderator to approve the injected comment, and a site visitor to click the affected image to open the lightbox.

Description from the CVE record, published by Wordfence (the CVE Numbering Authority), via the NVD entry for CVE-2026-103897.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit