Skip to content
Laskyr

CVE-2026-103681: Frontend Dashboard missing authorization check vulnerability

medium 4.3 published 2026-10-07

Fixed in Frontend Dashboard 3.0.0

Frontend Dashboard older than 3.0.0 is affected by this missing authorization issue. Sites on 3.0.0 or newer are not affected; the latest release is 3.1.1.

Affected versions
older than 3.0.0
Fixed in
3.0.0
Latest version
3.1.1
Severity
Medium · CVSS 4.3
Active installs
400+
Type
Missing authorization check

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

What to do now

  1. Update Frontend Dashboard to 3.0.0 or newer (the latest is 3.1.1): Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Frontend Dashboard issue. With WP-CLI: wp plugin get frontend-dashboard --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Frontend Dashboard WordPress plugin before 3.0.0 does not perform a capability check in one of its AJAX actions, allowing authenticated users with low privileges, such as subscribers, to delete the Frontend Dashboard WordPress plugin before 3.0.0's configured profile and post form fields.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-103681.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit