CVE-2026-100518: Advanced Google reCAPTCHA authentication bypass vulnerability
medium 5.3 published 2026-10-06
- Affected versions
- 5.40 and older
- Fixed in
- 5.41
- Latest version
- 5.42
- Severity
- Medium · CVSS 5.3
- Active installs
- 200,000+
- Type
- Authentication bypass
What an attacker needs
- Access: None. No account or login is needed (per the CVSS score).
CVSS vector (score by Patchstack): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
What to do now
- Update Advanced Google reCAPTCHA to 5.41 or newer (the latest is 5.42): Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- Not sure which version you run? Check your version against every known Advanced Google reCAPTCHA issue.
With WP-CLI:
wp plugin get advanced-google-recaptcha --field=version. - If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.
The advisory
Unauthenticated Broken Authentication in Advanced Google reCAPTCHA <= 5.40 versions.
References
- NVD CVE-2026-100518 nvd.nist.gov
- Patchstack advisory patchstack.com
Related
Ran an affected version? Check your site for signs of a hack
The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.
Where this data comes from
- CVE record, score and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Versions and install counts: wordpress.org/plugins/advanced-google-recaptcha (Plugins API), fetched 2026-11-04.
- The summary, “what an attacker needs” and “what to do” sections are our plain-English reading of the record and the plugin's release history; the quoted description is the record's own text. Spot an error? Email Daniel.