Skip to content
Laskyr

aws/aws-sdk-php security advisory

CVE-2025-14761: Key Commitment Issues in S3 Encryption Clients in aws/aws-sdk-php

CVE-2025-14761 is a medium-severity security vulnerability in the PHP package aws/aws-sdk-php (CVSS 5.3), published 17 December 2025. It is fixed in 3.368.0; earlier versions are affected. Exploiting it needs a low-privilege user account.

medium 5.3 published 2025-12-17 · updated 2026-06-17

Fixed in aws/aws-sdk-php 3.368.0

This security issue affects aws/aws-sdk-php versions >= 3.0.0, < 3.368.0. Upgrade to the fixed version for your release line (3.368.0). The newest release, 3.402.5, is not affected.

Affected versions
>= 3.0.0, < 3.368.0
Fixed in
3.368.0
Newest release
3.402.5
Severity
Medium · CVSS 5.3
Type
Security issue
CWE-327
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your aws/aws-sdk-php version affected?

Run composer show aws/aws-sdk-php in your project, then enter the version. We check it against this and every other known aws/aws-sdk-php advisory.

Who can exploit CVE-2025-14761

CVSS vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N

Your app is only exposed if it uses the affected part of aws/aws-sdk-php. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2025-14761 in aws/aws-sdk-php

  1. Find the installed version: composer show aws/aws-sdk-php. If you never required it yourself, composer why aws/aws-sdk-php shows which package pulls it in.
  2. Update it: composer update aws/aws-sdk-php --with-all-dependencies. You need 3.368.0 or newer.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "aws/aws-sdk-php": "^3.368.0" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2025-14761.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

The advisory gives this workaround:

To mitigate this issue, upgrade AWS SDK for PHP to version 3.368.0 or later

General hardening for this kind of issue while the upgrade waits. None of it replaces the fix.

The CVE-2025-14761 advisory

Missing cryptographic key commitment in the AWS SDK for PHP may allow a user with write access to the S3 bucket to introduce a new EDK that decrypts to different plaintext when the encrypted data key is stored in an "instruction file" instead of S3's metadata record. To mitigate this issue, upgrade AWS SDK for PHP to version 3.368.0 or later

Description from the CVE record, via the NVD entry for CVE-2025-14761. Advisory title: “Key Commitment Issues in S3 Encryption Clients”.

References

Other aws/aws-sdk-php advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit